Arthur de Jong

Open Source / Free Software developer

summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorArthur de Jong <arthur@arthurdejong.org>2008-05-02 17:57:23 +0200
committerArthur de Jong <arthur@arthurdejong.org>2008-05-02 17:57:23 +0200
commit28e48390ac6f11712160e6926a1c21277335db83 (patch)
tree5506efd626cd955edc1c7d9c4c72130b3d0d73b9 /tests/Makefile.am
parent49055801d8872217cbdede7d7dab5d30f3c61df7 (diff)
add file for testing nslcd/group.c
git-svn-id: http://arthurdejong.org/svn/nss-pam-ldapd/nss-ldapd@719 ef36b2f9-881f-0410-afb5-c4e39611909c
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0a242a4..bba61b3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -24,7 +24,8 @@ check_PROGRAMS = test_dict test_set test_tio test_cfg test_myldap
EXTRA_PROGRAMS = test_aliases test_ethers test_group test_hosts \
test_netgroup test_networks test_passwd test_protocols \
- test_rpc test_services test_shadow
+ test_rpc test_services test_shadow \
+ test_nslcd_group
EXTRA_DIST = nss-ldapd-test.conf test_myldap.sh test_nsscmds.sh usernames.txt
@@ -77,3 +78,13 @@ test_protocols_SOURCES = test_protocols.c ../nss/protocols.c $(common_SOURCES)
test_rpc_SOURCES = test_rpc.c ../nss/rpc.c $(common_SOURCES)
test_services_SOURCES = test_services.c ../nss/services.c $(common_SOURCES)
test_shadow_SOURCES = test_shadow.c ../nss/shadow.c $(common_SOURCES)
+
+test_nslcd_group_SOURCES = test_nslcd_group.c
+test_nslcd_group_LDADD = ../nslcd/log.o ../nslcd/attmap.o ../common/dict.o \
+ ../nslcd/common.o ../nslcd/myldap.o \
+ ../nslcd/alias.o ../nslcd/ether.o \
+ ../nslcd/host.o ../nslcd/netgroup.o ../nslcd/network.o \
+ ../nslcd/passwd.o ../nslcd/protocol.o ../nslcd/rpc.o \
+ ../nslcd/service.o ../nslcd/shadow.o \
+ @nslcd_LIBS@ ../common/libtio.a ../common/libdict.a \
+ ../compat/libcompat.a ../nslcd/cfg.o