Arthur de Jong

Open Source / Free Software developer

summaryrefslogtreecommitdiffstats
path: root/nss/Makefile.am
diff options
context:
space:
mode:
authorArthur de Jong <arthur@arthurdejong.org>2015-01-19 23:08:59 +0100
committerArthur de Jong <arthur@arthurdejong.org>2015-01-19 23:09:45 +0100
commitee82d2f519cc97aa433cf050b6c96d3430aa5a61 (patch)
treef95189a2fa6a9f018ddcd6b1fbb72721f5c24b0c /nss/Makefile.am
parented8b312f0968ce4fd9059b0ebb52d993cf3cdf36 (diff)
Allow configuration of NSS and PAM names
This introduces the --with-module-name configure option to allow building of NSS and PAM modules with different namespaces than ldap.
Diffstat (limited to 'nss/Makefile.am')
-rw-r--r--nss/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/nss/Makefile.am b/nss/Makefile.am
index 6bb2b24..cfa05e0 100644
--- a/nss/Makefile.am
+++ b/nss/Makefile.am
@@ -2,7 +2,7 @@
#
# Copyright (C) 2006 Luke Howard
# Copyright (C) 2006 West Consulting
-# Copyright (C) 2006, 2007, 2009, 2010, 2011 Arthur de Jong
+# Copyright (C) 2006-2015 Arthur de Jong
# Copyright (C) 2010 Symas Corporation
#
# This library is free software; you can redistribute it and/or
@@ -39,9 +39,13 @@ if NSS_FLAVOUR_FREEBSD
nss_ldap_so_LDADD += bsdnss.$(OBJEXT)
endif
nss_ldap_so_LDADD += ../common/libtio.a ../common/libprot.a
-nss_ldap_so_DEPENDENCIES = $(nss_ldap_so_LDADD)
+nss_ldap_so_DEPENDENCIES = $(nss_ldap_so_LDADD) exports.map
EXTRA_DIST = exports.glibc exports.solaris exports.freebsd
+CLEANFILES = exports.map
+
+exports.map: $(EXTRA_DIST)
+ sed 's/ldap/@MODULE_NAME@/' < $(srcdir)/exports.$(NSS_FLAVOUR) > exports.map
install-exec-local: install-nss_ldap_so
uninstall-local: uninstall-nss_ldap_so