Arthur de Jong

Open Source / Free Software developer

summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorArthur de Jong <arthur@arthurdejong.org>2011-08-30 20:47:39 +0200
committerArthur de Jong <arthur@arthurdejong.org>2011-08-30 20:47:39 +0200
commit7da6b32e51313c3b6de45c1507a69ff297e3d332 (patch)
tree89bd7d3fdef5b00b59bd9bcf031c49569bec8ed8 /configure.ac
parentef4080e37a8827ba611246465c448b2324bada41 (diff)
move LDAP_DEPRECATED and LDAP_REFERRALS to configure.ac to ensure that tests from configure see the same API
git-svn-id: http://arthurdejong.org/svn/nss-pam-ldapd/nss-pam-ldapd@1529 ef36b2f9-881f-0410-afb5-c4e39611909c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2f123e5..315f5c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -606,6 +606,11 @@ then
CFLAGS="$pthread_save_CFLAGS"
LIBS="$pthread_save_LIBS"
+ # also use deprecated LDAP functions
+ AC_DEFINE(LDAP_DEPRECATED, 1, Define to activate deprecated features in OpenLDAP)
+ # for compatibility on Solaris
+ AC_DEFINE(LDAP_REFERRALS, 1, Define to get some functions on Solaris)
+
# search for an LDAP library (only OpenLDAP is tested)
AC_ARG_WITH(ldap-lib,
AS_HELP_STRING([--with-ldap-lib=TYPE],