Arthur de Jong

Open Source / Free Software developer

summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorArthur de Jong <arthur@arthurdejong.org>2010-10-11 22:58:05 +0200
committerArthur de Jong <arthur@arthurdejong.org>2010-10-11 22:58:05 +0200
commit147840dcf4a3ed565ca8311f8a3d489c668126cb (patch)
treecfae8fa9edb2a9c000873c339e2e4c36175438af /configure.ac
parent90fec72d7d1390d0744622928c6648355d3f6f33 (diff)
always define {nss,pam}_ldap_so_LINK (defaults to default) because otherwise automake gets confused
git-svn-id: http://arthurdejong.org/svn/nss-pam-ldapd/nss-pam-ldapd-solaris@1263 ef36b2f9-881f-0410-afb5-c4e39611909c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b0108e6..0785d4d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -415,11 +415,12 @@ then
AC_SUBST(NSS_MODULE_OBJS)
# find out how to link the library
+ nss_ldap_so_LINK="\$(CCLD) \$(AM_CFLAGS) \$(CFLAGS) \$(nss_ldap_so_LDFLAGS) \$(LDFLAGS) -o \$@"
case "$target_os" in
solaris*)
- if test "$ac_cv_prog_gcc" = yes; then
+ if test "$ac_cv_prog_gcc" = yes
+ then
nss_ldap_so_LINK="/usr/ccs/bin/ld -Bdirect -z nodelete -Bdynamic -M \$(srcdir)/exports.solaris -G -o \$@"
- AC_SUBST(nss_ldap_so_LINK)
else
nss_ldap_so_LDFLAGS="-Wl,-Bdirect -Wl,-z,nodelete -Wl,-Bdynamic -Wl,-M,\$(srcdir)/exports.solaris -Wl,-G"
fi
@@ -429,6 +430,7 @@ then
;;
esac
AC_SUBST(nss_ldap_so_LDFLAGS)
+ AC_SUBST(nss_ldap_so_LINK)
# restore CFLAGS and LIBS
CFLAGS="$nss_save_CFLAGS"
@@ -468,11 +470,12 @@ then
AC_CHECK_FUNCS(pam_modutil_getpwnam pam_syslog)
# find out how to link the library
+ pam_ldap_so_LINK="\$(CCLD) \$(AM_CFLAGS) \$(CFLAGS) \$(pam_ldap_so_LDFLAGS) \$(LDFLAGS) -o \$@"
case "$target_os" in
solaris*)
- if test "$ac_cv_prog_gcc" = yes; then
+ if test "$ac_cv_prog_gcc" = yes
+ then
pam_ldap_so_LINK="/usr/ccs/bin/ld -Bdirect -z nodelete -Bdynamic -M \$(srcdir)/pam_ldap.map -G -o \$@"
- AC_SUBST(pam_ldap_so_LINK)
else
pam_ldap_so_LDFLAGS="-shared -Wl,-Bdirect -Wl,-z,nodelete -Wl,-Bdynamic -Wl,-M,\$(srcdir)/pam_ldap.map -Wl,-G"
fi
@@ -482,6 +485,7 @@ then
;;
esac
AC_SUBST(pam_ldap_so_LDFLAGS)
+ AC_SUBST(pam_ldap_so_LINK)
# restore CFLAGS and LIBS
CFLAGS="$pam_save_CFLAGS"