Arthur de Jong

Open Source / Free Software developer

summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorArthur de Jong <arthur@arthurdejong.org>2014-06-05 23:16:23 +0200
committerArthur de Jong <arthur@arthurdejong.org>2014-06-05 23:16:23 +0200
commit13483f9f91c1fe4f3257f1d6b42eb1d01b3c6ba3 (patch)
treeb3170a651f2eb0c566e396f0ef2cf19a0425bbb1 /configure.ac
parent3d29861e86e2044dc4dfbf6f2615c3e567c7a4f6 (diff)
Introduce lookup_groupbyuser test command
This command can be used to perform a lookup using getgrouplist() to present a list of returned numeric group ids. This can be used to avoid the additional lookups that are done with the id and groups commands.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 96ae06f..bc15d80 100644
--- a/configure.ac
+++ b/configure.ac
@@ -345,7 +345,7 @@ AC_CHECK_FUNCS([malloc realloc atexit])
AC_FUNC_FORK
AC_CHECK_FUNCS(__assert_fail)
AC_SEARCH_LIBS(clock_gettime, rt)
-AC_CHECK_FUNCS([setusershell getusershell endusershell])
+AC_CHECK_FUNCS([setusershell getusershell endusershell getgrouplist])
AC_CHECK_DECLS([setusershell, getusershell, endusershell])
# checks for types