Arthur de Jong

Open Source / Free Software developer

summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorArthur de Jong <arthur@arthurdejong.org>2017-06-13 21:39:29 +0200
committerArthur de Jong <arthur@arthurdejong.org>2017-06-13 22:00:38 +0200
commitbe2651072b8cd77fc335ad8248512099f7d858eb (patch)
tree839ca6157c60b8cac33cc0a7898fcad4c51e0fe2 /configure.ac
parentbecc883693df2ad812cfd7ba4a5dcbd1d1a8fa3f (diff)
Query ethernet addresses in compact and long format
This ensures that when querying the address 0:18:8a:54:1a:8b both that format and 00:18:8a:54:1a:8b is searched for in LDAP. This was triggerred by the fact that ether_ntoa() on FreeBSD returns the long format while glibc uses the compact format. Since we are no longer using the libc version of ether_ntoa() we can also drop the compatibility implementation of ether_ntoa_r().
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e7a37e4..63f2f19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
#
# Copyright (C) 2006 Luke Howard
# Copyright (C) 2006 West Consulting
-# Copyright (C) 2006-2016 Arthur de Jong
+# Copyright (C) 2006-2017 Arthur de Jong
#
# This library is free software; you can redistribute it and/or
# modify it under the terms of the GNU Lesser General Public
@@ -720,8 +720,8 @@ then
AC_REPLACE_FUNCS(getopt_long)
AC_REPLACE_FUNCS(strndup)
- # replace ether_aton_r() and ether_ntoa_r() if they are not found
- AC_CHECK_FUNCS(ether_aton_r ether_ntoa_r,, [AC_LIBOBJ(ether)])
+ # replace ether_aton_r() if not found
+ AC_CHECK_FUNCS(ether_aton_r,, [AC_LIBOBJ(ether)])
# check to see if struct sockaddr_storage is defined
AC_CHECK_TYPE(struct sockaddr_storage,,