Arthur de Jong

Open Source / Free Software developer

summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorArthur de Jong <arthur@arthurdejong.org>2013-09-13 15:53:08 +0200
committerArthur de Jong <arthur@arthurdejong.org>2013-09-15 16:08:51 +0200
commitb7ca95a4f853296e82dc0a830ac9f724416fd4c0 (patch)
tree7f3430b2d144b0adbe012df4d34b564aef384372 /configure.ac
parentf36bb819ca61b7c617f754574b0748b6eee44aba (diff)
Make missing Python modules a waring
This avoids having to have all modules installed in the build environment. A Python version is still required during build.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 979eab6..0497fd4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -614,7 +614,7 @@ then
AX_PYTHON_MODULE(argparse)
if test "x$HAVE_PYMOD_ARGPARSE" != "xyes"
then
- AC_MSG_ERROR(Required Python modules missing)
+ AC_MSG_WARN(Required Python modules missing)
fi
fi
@@ -856,7 +856,7 @@ then
test "x$HAVE_PYMOD_LDAP" != "xyes" || \
test "x$HAVE_PYMOD_SQLITE3" != "xyes"
then
- AC_MSG_ERROR(Required Python modules missing)
+ AC_MSG_WARN(Required Python modules missing)
fi
fi