Arthur de Jong

Open Source / Free Software developer

summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorArthur de Jong <arthur@arthurdejong.org>2010-10-04 19:16:15 +0200
committerArthur de Jong <arthur@arthurdejong.org>2010-10-04 19:16:15 +0200
commit9d172a45a64bbdbdbb31cdc50ae426e9dcf5e470 (patch)
treeaa693b31cf1b90cb6574bdfcead81ba549eb3379 /configure.ac
parentbebac035f67df5083daba4613c77cbc412faee86 (diff)
add check for returnlen member of struct nss_XbyY_args
git-svn-id: http://arthurdejong.org/svn/nss-pam-ldapd/nss-pam-ldapd-solaris@1237 ef36b2f9-881f-0410-afb5-c4e39611909c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f6c65b7..4954d55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -362,6 +362,24 @@ then
#include "irs-nss.h"
#endif])
+ # check if struct nss_XbyY_args has a returnlen attribute
+ AC_CHECK_MEMBER([struct nss_XbyY_args.returnlen],,,[[
+ #ifdef HAVE_NSS_H
+ #include <nss.h>
+ #endif
+ #ifdef HAVE_NSS_COMMON_H
+ #include <nss_common.h>
+ #endif
+ #ifdef HAVE_NSS_DBDEFS_H
+ #include <nss_dbdefs.h>
+ #endif
+ #ifdef HAVE_NSSWITCH_H
+ #include <nsswitch.h>
+ #endif
+ #ifdef HAVE_IRS_NSS_H
+ #include "irs-nss.h"
+ #endif]])
+
# check which NSS flavour to build
AC_MSG_CHECKING([which NSS flavour to build])
AC_ARG_WITH(nss-flavour,